Centre de Chirurgie Plastique Lausanne swissaesthetic


You don't have the last version of Adobe Flash Player installed on your computer.

Version 8.0.0 is required to go on our web site and many others.

But don't worry, it's easy and fast :


1) Update Flash Player

(follow the instructions)
download: 1 mn with 56K modem or a few seconds with ADSL


2) www.swissaesthetic.ch





Map